Altium Tips and Tricks

Just a gathering point for various things I’ve learned.

Proper Way to Re-annotate/Back-annotate

I sometimes had a hell of time with re-annotation causing strange problems with duplicate reference designators and other strange problems which were completely repeatable. I found this step-by-step on this site, but the site is full of slow javascript and other cruft.

  1. Compile your project (Project → Compile PCB Project) and ensure that there are no relevant errors connected with component designators (e.g. duplicated designators and so on)
  2. Verify that board and schematics are up to date (from the PCB Editor, use Design → Import changes... and in Schematic Editor use Design → Update Schematics)
  3. From the PCB Editor, verify that there are no un-matched components in Component Links (Project → Component Links...)
  4. Proceed to re-annotate designators from PCB Editor going to Tools → Re-Annotate using the desired annotation strategy
  5. From the PCB Editor go to Design → Update schematics and accept the ECO
  6. IMPORTANT: do not skip this step! Force Altium to accept all new designators by recompiling the project using (Project → Compile PCB Project)
  7. The previous step causes all net names to change (because the component designators change), with the exception of the user-defined nets. You need to sync net names between Schematics and the PCB Editor from inside the PCB Editor (doing it from the schematic editor causes weird problems sometimes). Do this with Design → Import Changes...
Add picture from clipboard (Maximum size: 1 GB)